Flits Draughts for iOS

For iPhone, iPad and iPod touch (5th generation). Requires iOS 7 or higher.

iOS app on iTunes